Monthly Archives: March 2016

Prepar3D v3.2 is supported

All of our installers now support P3D v3.2 thanks to an update by FSDT. Simply install using the same installer and updated files will be fetched during installation.
As always, our downloads page is located right here: http://www.flightbeam.net/downloads.html